Export de layout sous KiCAD

Il m'a fallu 16 essais pour réussir à sortir un typon potable. Voici un process qui marche.
EDIT : Il semble que je soit le seul à l'Electrolab à rencontrer le problème.

Une fois qu'on a un layout fini sous KiCAD, il faut imprimer le typon et fabriquer. Voici comment je m'y prends pour imprimer le typon.

  1. Sous KiCAD, faire Fichier / Tracer (pas Export SVG).
  2. Format du tracé : SVG.
  3. Décocher toutes les couches sauf F.Cu, cocher Tracé miroir, puis Tracer.
  4. Décocher F.Cu, cocher B.Cu, décocher Tracé miroir, puis Tracer. Vous venez de créer deux fichiers SVG dans le répertoire projet.
  5. Ouvrir les fichiers avec Inkscape, faire le post-process (ajout de logo, panellisation ...).
  6. Enregistrer sous ou Enregistrer copie, choisir le format PDF.
  7. Choisir une résolution la plus élevée possible. Moi j'ai mis 30 000 ppp (j'ai mis cette valeur au pif, elle donne un résultat correct, mais je pense que d'autres valeurs pourraient aller).
  8. Ouvrir le PDF avec un lecteur de PDF et imprimer en qualité max, échelle 1:1.


Voilà ce à quoi j'ai eu droit en faisant autrement:

  • En imprimant directement depuis KiCAD : feuille noire.
  • En imprimant le SVG en direct depuis Inkscape, les pads ne sont pas imprimés, les angles des pistes sont cassés. Pourtant ils sont affichés correctement dans Inkscape ...
  • En ouvrant le SVG dans un autre logiciel (genre Firefox ou Edge) -> idem
  • Export PNG depuis Inkscape, même avec une résolution élevée les bords sopnt crenellés.


Avec ma méthode on a toujours des bords crevellés à l'impression, mais moins qu'avec les PNG. Je n'ai aucune idée de la vraie origine du problème. Un problème de driver ? (Dell 1720 sous W10) En problème intrinsèque à Inkscape ?

Add ping

Trackback URL : http://blog.randagodron.eu/index.php?trackback/55

Page top